Ranking services down

Incident Report for Campfire HQ

Resolved

This incident has been resolved.
Posted Jul 17, 2020 - 12:44 UTC

Investigating

We are currently investigating this issue.
Posted Jul 17, 2020 - 11:54 UTC