Degraded ranking performance

Incident Report for Campfire HQ

Resolved

Roblox has recovered and Campfire Ranking requests are now operational.
Posted Oct 11, 2020 - 19:30 UTC

Identified

A Roblox issue causing decreased performance on the platform is impacting performance of Campfire Ranking.
Posted Oct 11, 2020 - 17:57 UTC

Investigating

We are currently investigating this issue.
Posted Oct 11, 2020 - 17:32 UTC
This incident affected: Ranking.