Roblox.com down
Incident Report for Campfire HQ
Resolved
This incident has been resolved.
Posted Jul 01, 2020 - 20:49 UTC
Monitoring
The site is now resumed. We are monitoring and will update if the situation changes.
Posted Jul 01, 2020 - 18:56 UTC
Identified
Issues are still occuring. We will update you as required.
Posted Jul 01, 2020 - 18:48 UTC
Monitoring
The site now back up. Our team are continuing to monitor and will keep you updated should issueso occur again.
Posted Jul 01, 2020 - 18:44 UTC
Update
The site is now coming back online slowly.
Posted Jul 01, 2020 - 18:42 UTC
Identified
Roblox.com is currently down.
Posted Jul 01, 2020 - 18:37 UTC